angular npm エラー

エラー内容

codelyzer@3.2.2 requires a peer of @angular/compiler@^2.3.1 || >=4.0.0-beta <5.0.0 but none is installed. You must install peer dependencies yourself.

解決方法

package.json 修正
4.0.1 に変更

 "codelyzer": "~4.0.1",

参考

it seems to work updating codelyzer to the latest version (4.0.1) and using angular/material2-builds angular/cdk-builds… we should wait to update to ng 5 using material 👍

https://github.com/angular/material2/issues/8246